PHP Found Mental

Semicoon(;)

Apabila Anda perhatikan contoh sebelumnya, maka terdapat tanda titik koma (semicolon) pada
akhir perintah echo. Tanda semicolon merupakan penanda akhir dari statement PHP dan harus
ada.

Contoh

Halaman PHP

Variabel

Misalkan dalam PHP kita akan menyimpan suatu nilai berupa angka atau string dalam suatu variabel, caranya adalah membuat nama variabel terlebih dahulu kemudian diberikan suatu assignment pada nilai yang diinginkan. Perhatikan sintaks berikut ini :
$nama_variabel = nilai;

Note: jangan lupa tanda dollar ($)

Contoh

Dari contoh di atas tampak bahwa dalam PHP, nama variabel tidak perlu dideklarasikan terlebih dahulu seperti halnya bahasa Pascal atau C/C++.

Iklan

Holiday To Lombok

me Sengigi

Pagi Temen- temen yang suka ngeblog dan nulis di jendala maya ,, kali penulis ingin berbagi pengalama tentang petualangan penulis selama di lombok ,, ada beberapa pantai yang ada di lombok kalau penulis hitun ada 10 pantai yang sangat bagus dan romantis untuk liburan ke lombok sungguh sangat istimewa pantai lombok berikut daftar pantai yang penulis dapat dari google ckckck

1.Pantai Kuta

2. Pantai Gili Trawangan

3. Pantai Gerupuk

4. Pantai Selong Balanak

5. Pantai mawun

6. Pantai Ringgit

7. Pantai Bangko bangko

8.  Pantai segar

9. Pantai Senggigi

itulah daftar pantai yang penulis tahu tapi penulis cuman bisa kunjungi ke pantai  Pantai Senggigi dan Gili Trawangan ,, itulah yang dapat penulis kunjungi karena keterbatasan waktu

konfigurasi 3 router dengan routing OSPF

oSPF
R1(config)#interface loopback 0
R1(config-if)#ip address 1.1.1.1 255.255.255.255
R1(config-if)#exit

konfigurasikan setiap router yang ada kita lanjutkan langsung ke routing OSPF

Konfugurasi routing protocol pada R1

R1>enable
R1#configure terminal
R1(config)#router ospf 100
R1(config-router)#network 2.2.2.2 0.0.0.0 area 0
R1(config-router)#network 10.0.0.0 0.0.0.255 area 0
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0

Konfugurasi routing protocol pada R0

R0>enable

R0(config)#router ospf 100
R0(config-router)#network 1.1.1.1      0.0.0.0 area 0
R0(config-router)#network 10.0.0.0 0.0.0.255 area 0
R0(config-router)#network 11.0.0.0  0.0.0.255 area 0

Konfigurasi routing protocol pada R3

R2>enable
R2#configure terminal
R2#configure terminal
R2(config)#router ospf 100
R2(config-router)#network 3.3.3.3 0.0.0.0 area 0
R2(config-router)#network 11.0.0.0 0.0.0.255 area 0
R2(config-router)#network 172.168.1.0 0.0.0.255 area 0

Setelah dikonfigurasikan dengan benar maka ROUTING OSPF pasti berkerja dengan benar .

sampai disini dulu ya .. posting nya …jika ada masukan silahkan komentar ::: heh 🙂

 

 

Konfigurasi 3 router dengan Routing protokol BGP

BGP

Gambar di atas Adalah hasil Dari desain yang ingin kita implementasikan

Langkah pertama tentu seting IP address pada masing masing router

R1>enable

Pada Router 1 (R1) untuk interface serial 0/0/0

R1#configure terminal
R1(config)#interface serial 0/0/0
R1(config-if)#ip address 20.20.20.1 255.255.255.252
R1(config-if)#clock rate 64000 ( menggunakan kabel DCE )
R1(config-if)#no shutdown
Pada Router 1 (R1) untuk interface loopback 1 dan loopback 2
R1(config-if)#exit
R1(config)#interface loopback 1
R1(config-if)#ip address 1.0.0.1 255.0.0.0
R1(config-if)#exit

R1(config)#interface loopback 1
R1(config-if)#ip address 2.0.0.1 255.0.0.0
R1(config-if)#exit

Pada Router 1 (R1) untuk interface serial 0/0/1

R1(config)#interface serial 1/1
R1(config-if)#ip address 10.10.10.1 255.255.255.252
R1(config-if)#no shutdown

Pada Router 0 (R0) untuk interface serial 0/0/0

R0>enable
R0#configure terminal
R0(config)#interface serial 0/0/0
R0(config-if)#ip address 20.20.20.2 255.255.255.252
R0(config-if)#no shutdown

Pada Router 2 (R2) untuk interface serial 0/0/1

R3>enable
R3#configure terminal
R3(config)#interface serial 0/0/1
R3(config-if)#ip address 10.10.10.2 255.255.255.252
R3(config-if)#no shutdown

IP pada masing masing router sudah terseting, sekarang waktunya untuk konfigurasi masing masing routing protocol pada masing masing router

Konfugurasi routing protocol pada R1

R1>enable
R1#configure terminal
R1(config)#router bgp 300
R1(config-router)#network 1.0.0.0
R1(config-router)#network 2.0.0.0
R1(config-router)#neighbor 10.10.10.2 remote-as 100
R1(config-router)#neighbor 20.20.20.2 remote-as 200

Konfugurasi routing protocol pada R2

R2>enable
R2#configure terminal
R2(config)#router bgp 100
R2(config-router)#neighbor 20.20.20.1 remote-as 300

Konfigurasi routing protocol pada R3

R0>enable
R0#configure terminal
R0(config)#router bgp 200
R0(config-router)#neighbor 10.10.10.1 remote-as 300

Okay routing protocol BGP sudah terkonfigurasi di masing masing router. Untuk membuktikannya maka lakukan ping ke dari masing masing router ke semua interface, tapi sebelumnya kita cek running config pada R1, R2, R0. Dan jangan lupa juga menambahkan ip route pada masing masing router.

pada R1

R1#configure terminal

R1#ip route 0.0.0.0 0.0.0.0 10.10.10.0

R1#ip route 0.0.0.0 0.0.0.0 20.20.20.0

pada R0
R2#configure terminal
R2#ip route 0.0.0.0 0.0.0.0 20.20.20.0

pada R2
R3#configure terminal
R3#ip route 0.0.0.0 0.0.0.0 10.10.10.0

akhir nya selesai juga routing protokol dengan menggunakn BGP mudah – mudahan penulis dapat bertambah ilmu dan beserta temen2 yang membaca nya .. ami ,, 🙂 sampai disin dulu ya . postingan nya ,.. nanti akan kita sambung dengan routing protokol OSPF next ,,,

Konfigurasi 3 router dengan routing EIGRP

Salam Semangat Temen ,,,,,

Pada kesempatan ini, admin ingin mecoba membahas bagaimana mengkonfigurasikan 3 router dengan routing EIGRP ,tapi sebelum melangkah lebih lanjut sangat disarankan untuk mengetahui Apasih EIGRP itu berikut link nya :

jika temen2 sudah mengerti apa itu EIGRP sekarang mari kita membuatnya  🙂EIGRP

Gambar di atas adalah hasil dari yang ingin kita buat :

 
LAN PC 0 :
IP 198.168.1.2
Subnet Mask 255.255.255.0
Gateway 198.168.1.1
LAN LAPTOP:
IP 172.16.0.2
Subnet Mask 255.255.0.0
Gateway 172.16.0.1

ROUTER 2 :
fast ethernet 0/0 : 172.168.1.1
serial 0/0/1 : 200.0.0.2

ROUTER 1 :
fast ethernet 0/0 : 192.168.1.1
serial 0/0/0 :100.0.0.1
serial 0/0/1 : 200.0.0.1

ROUTER 0 :
fast ethernet 0/0 : 192.168.1.2
serial 0/0/0 :100.0.0.2

Konfigurasinya adalah sebagai berikut :

ROUTER 1 :

router# configure terminal
router1(config)#interface serial 0/0/0
router1(config-if)#ip address 100.0.0.1  255.255.0.0
router1(config-if)#no shutdown
router1(config-if)#exit
router1(config)#interface serial 0/0/1
router1(config-if)#ip address 200.0.0.1  255.0.0.0
router1(config-if)#clock rate 64000 (jika memakai kabel DCE )
router1(config-if)#no shutdown
router1(config-if)#exit
router1(config)#router eigrp 10
router1(config-router)#network 100.0.0.0
router1(config-router)#network 200.0.0.0
router1(config-router)#exit
router1(config)#exit

ROUTER 2 :

router# configure terminal
router(config)#hostname router2
router2(config)#interface fastethernet 0/0
router2(config-if)#ip address 172.168.1.1  255.255.0.0
router2(config-if)#no shutdown
router2(config-if)#exit
router2(config)#interface serial 0/0/1
router2(config-if)#ip address 200.0.0.2 255.0.0.0
router2(config-if)#no shutdown
router2(config-if)#exit
router2(config)#router eigrp 10
router2(config-router)#network 172.168.1.0
router2(config-router)#network 200.0.0.0
router2(config-router)#exit
router2(config)#exit

ROUTER 3 :

router# configure terminal
router(config)#hostname router3
router3(config)#interface fastethernet 0/0
router3(config-if)#ip address 192.168.1.1 255.255.255.0
router3(config-if)#no shutdown
router3(config-if)#exit
router3(config)#interface serial0/0/0
router3(config-if)#ip address 100.0.0.2  255.0.0.0
router3(config-if)#no shutdown
router3(config-if)#exit
router3(config)#router eigrp 10
router3(config-router)#network 100.0.0.0
router3(config-router)#network 192.168.1.0
router3(config-router)#exit
router3(config)#exit
Diatas tadi merupakan konfigurasi dari Router yang menggunakan Routing Protocol EIGRP. Kita dapat melihat diatas, bahwa masing-masing Router memiliki Autonomous System (AS) yang sama, yaitu 10. Yang menandakan bahwa Router-Router tersebut berada dalam satu lingkup yang sama. Apabila kita membandingkan dengan konfigurasi menggunakan Routing Information Protocol (RIP), pada EIGRP ini, kita tidak perlu menuliskan lagi Network-Network yang terhubung pada Router-Router tetangga, karena pada EIGRP ini, akan mencari sendiri Routing Table dari Router tetangganya. Selain itu juga EIGRP dapat mengatasi masalah pada RIP dalam hal keterbatasan jumlah hop maksimum yang dimiliki oleh RIP.

Cukup sampai disini dulu pembahasan mengenai tutorial untuk membangun routing protocol EIGRP pada Cisco mudah- mudahan bermamfaat bagi saya sendiri dan temen2 yang membacanya amin ,,,

CCNA EIGRP

Salam semangat ,,, temen2 dunia maya 🙂

EIGRP adalah protokol routing yang termasuk proprietari Cisco, yang berarti hanya bisa dijalankan pada router Cisco, EIGRP bisa jadi merupakan protokol routing terbaik didunia jika bukan merupakan proprietari Cisco.

Kelebihan utama yang membedakan EIGRP dari protokol routing lainnya adalah EIGRP termasuk satu-satunya protokol routing yang menawarkan fitur backup route, dimana jika terjadi perubahan pada network, EIGRP tidak harus melakukan kalkulasi ulang untuk menentukan route terbaik karena bisa langsung menggunakan backup route. Kalkulasi ulang route terbaik dilakukan jika backup route juga mengalami kegagalan. Berikut adalah fitur-fitur yang dimiliki EIGRP:

  • Termasuk protokol routing distance vector tingkat lanjut (Advanced distance vector).
  • Waktu convergence yang cepat.
  • Mendukung VLSM dan subnet-subnet yang discontiguous (tidak bersebelahan/berurutan)
  • Partial updates, Tidak seperti RIP yang selalu mengirimkan keseluruhan tabel routing dalam pesan Update, EIGRP menggunakan partial updates atau triggered update yang berarti hanya mengirimkan update jika terjadi perubahan pada network (mis: ada network yang down)
  • Mendukung multiple protokol network
  • Desain network yang flexible.
  • Multicast dan unicast, EIGRP saling berkomunikasi dengan tetangga (neighbor) nya secara multicast (224.0.0.10) dan tidak membroadcastnya.
  • Manual summarization, EIGRP dapat melakukan summarization dimana saja.
  • Menjamin 100% topologi routing yang bebas looping.
  • Mudah dikonfigurasi untuk WAN dan LAN.
  • Load balancing via jalur dengan cost equal dan unequal, yang berarti EIGRP dapat menggunakan 2 link atau lebih ke suatu network destination dengan koneksi bandwidth (cost metric) yang berbeda, dan melakukan load sharing pada link-link tersebut dengan beban yang sesuai yang dimiliki oleh link masing-masing, dengan begini pemakaian bandwidth pada setiap link menjadi lebih efektif, karena link dengan bandwidth yang lebih kecil tetap digunakan dan dengan beban yang sepadan juga

EIGRP mengkombinasikan kelebihan-kelebihan yang dimiliki oleh protokol routing link-state dan distance vector. Tetapi pada dasarnya EIGRP adalah protokol distance vector karena router-router yang menjalankan EIGRP tidak mengetahui road map/ topologi network secara menyeluruh seperti pada protokol link-state.

EIGRP mudah dikonfigurasi seperti pendahulunya (IGRP) dan dapat diadaptasikan dengan variasi topologi network. Penambahan fitur-fitur protokol link-state seperti neighbor discoverymembuat EIGRP menjadi protokol distance vector tingkat lanjut.

EIGRP menggunakan algoritma DUAL (Diffusing Update Algorithm) sebagai mesin utama yang menjalankan lingkungan EIGRP, DUAL dapat diperbandingkan dengan algoritma SPF Dijkstra pada OSPF.

EIGRP memiliki fitur-fitur utama sebagai berikut.

  • Partial updates: EIGRP tidak mengirimkan update secara periodik seperti yang dilakukan oleh RIP, tetapi EIGRP mengirimkan update hanya jika terjadi perubahan route/metric (triggered update). Update yang dikirimkan hanya berisi informasi tentang route yang mengalami perubahan saja. Pengiriman pesan update ini juga hanya ditujukan sebatas pada router-router yang membutuhkan informasi perubahan tersebut saja. Hasilnya EIGRP menghabiskan bandwidth yang lebih sedikit daripada IGRP. Hal ini juga membedakan EIGRP dengan protokol link-state yang mengirimkan update kepada semua router dalam satu area.
  • Multiple network-layer protocol support: EIGRP mendukung protokol IP, AppleTalk, dan Novell NetWare IPX dengan memanfaatkan module-module yang tidak bergantung pada protokol tertentu.

Fitur EIGRP lain yang patut diperhatikan adalah sebagai berikut:

  •  Koneksi dengan semua jenis data link dan topologi tanpa memerlukan konfigurasi lebih lanjut, protokol routing lain seperti OSPF, menggunakan konfigurasi yang berbeda untuk protokol layer 2 (Data Link) yang berbeda, misalnya Ethernet dan Frame Relay. EIGRP beroperasi dengan efektif pada lingkungan LAN dan WAN. Dukungan WAN untuk link point-to-point dan topologi nonbroadcast multiaccess (NBMA) merupakan standar EIGRP.
  • Metric yang canggih: EIGRP menggunakan algoritma yang sama dengan IGRP untuk menghitung metric tetapi menggambarkan nilai-nilai dalam format 32-bit. EIGRP mendukung load balancing untuk metric yang tidak seimbang (unequal), yang memungkinkan engineer untuk mendistribusikan traffik dalam network dengan lebih baik.
  • Multicast and unicast: EIGRP menggunakan multicast dan unicast sebagai ganti broadcast. Address multicast yang digunakan adalah 224.0.0.10.

Dibalik Proses dan Teknologi EIGRP

EIGRP menggunakan 4 teknologi kunci yang berkombinasi untuk membedakan EIGRP dengan protokol routing yang lainnya:  neighbor discovery/recovery, reliable transport protocol (RTP),DUAL finitestate machine, dan protocol-dependent modules.

  • Neighbor discovery/recovery
    • Menggunakan paket hello antar neighbor.
  • Reliable Transport Protocol (RTP)
    • Pengiriman paket yang terjamin dan terurut kepada semua neighbor.
  • DUAL finite-state machine
    • Memilih jalur dengan cost paling rendah dan bebas looping untuk mencapai destination.
  • Protocol-dependent module (PDM)
    • EIGRP dapat mendukung IP, AppleTalk, dan Novell NetWare.
    • Setiap protokol disediakan modul EIGRP tersendiri dan beroperasi tanpa saling mempengaruhi satu sama lain.

Neighbor discovery/recovery mechanism: teknologi ini memungkinkan router untuk dapat mengenali setiap neighbor pada network yang terhubung langsung secara dinamik. Router juga harus mengetahui jika ada salah satu neighbor yang mengalami kegagalan dan tidak dapat dijangkau lagi (unreachable). Proses ini dapat diwujudkan dengan pengiriman paket hello yang kecil secara periodik. Selama router menerima paket hello dari router neighbor, maka router akan mengasumsikan bahwa router neighbor berfungsi dengan normal dan keduanya dapat bertukar informasi routing.

RTP: Bertanggung jawab atas pengiriman paket-paket kepada neighbor yang terjamin dan terurut. RTP mendukung transmisi campuran antara paket multicast dan unicast. Untuk tujuan efisiensi, hanya paket EIGRP tertentu yang dikirim menggunakan teknologi RTP.

DUAL finite state machine: mewujudkan proses penentuan untuk semua komputasi route. DUAL melacak semua route yang di advertise oleh setiap neighbor dan menggunakan metric untuk menentukan jalur paling effisien dan bebas looping ke semua network tujuan.

Protocol-dependent modules (PDM): bertanggung jawab untuk keperluan layer network protokol-protokol tertentu. EIGRP mendukung IP, AppleTalk, dan Novell NetWare; setiap protokol tersebut telah disediakan module EIGRP nya masing-masing dan satu sama lain beroperasi secara independent. Module IP-EIGRP misalnya, bertanggung jawab untuk pengiriman dan penerimaan paket-paket EIGRP yang telah di enkapsulasi dalam IP.

Cara Kerja EIGRP

Istilah-istilah algoritma DUAL

  • Memilih jalur/route untuk mencapai suatu network dengan ongkos paling rendah, danbebas looping.
  • AD (advertised distance), menggambarkan seberapa jauh sebuah network dari neighbor, merupakan ongkos (metric) antara router next-hop dengan network destination.
  • FD (feasible distance), menggambarkan seberapa jauh sebuah network dari router, merupakan ongkos (metric) antara router dengan router next-hop ditambah dengan AD dari router next-hop.
  • Ongkos paling rendah = FD paling rendah.
  • Successor, adalah jalur utama untuk mencapai suatu network (route terbaik), merupakan router next-hop dengan Ongkos paling rendah dan jalur bebas looping.
  • Feasible Successor, adalah jalur backup dari successor (AD dari feasible successor harus lebih kecil daripada FD dari successor)

EIGRP menggunakan dan memelihara 3 jenis tabel. Tabel neighbor untuk mendaftar semua router neighbor, tabel topologi untuk mendaftar semua entri route untuk setiap network destination yang didapatkan dari setiap neighbor, dan tabel routing yang berisi jalur/route terbaik untuk mencapai ke setiap destination.

Table Neighbor

1-neighbor-table

Ketika router menemukan dan menjalin hubungan adjacency (ketetanggaan) dengan neighbor baru, maka router akan menyimpan address router neighbor beserta interface yang dapat menghubungkan dengan neighbor tersebut sebagai satu entri dalam tabel neighbor. Tabel neighbor EIGRP dapat diperbandingkan dengan database adjacency yang digunakan oleh protokol routing link-state yang keduanya mempunyai tujuan yang sama: untuk melakukan komunikasi 2 arah dengan setiap neighbor yang terhubung langsung.

Ketika neighbor mengirimkan paket hello, ia akan menyertakan informasi hold time, yakni total waktu sebuah router dianggap sebagai neighbor yang dapat dijangkau dan operasional. Jika paket hello tidak diterima sampai hold time berakhir, algoritma DUAL akan menginformasikan terjadinya perubahan topologi.

Topology Table

2-topology-table

Ketika router menemukan neighbor baru, maka router akan mengirimkan sebuah update mengenai route-route yang ia ketahui kepada neighbor baru tersebut dan juga sebaliknya menerima informasi yang sama dari neighbor. Update-update ini lah yang akan membanguntabel topologi. Tabel topologi berisi informasi semua network destination yang di advertise oleh router neighbor. Jika neighbor meng advertise route ke suatu network destination, maka neighbor tersebut harus menggunakan route tersebut untuk memforward paket.

Tabel topologi di update setiap kali ada perubahan pada network yang terhubung langsung atau  pada interface atau ada pemberitahuan perubahan pada suatu jalur dari router neighbor.

Entri pada tabel topologi untuk suatu destination dapat berstatus active atau passive. Destination akan berstatus passive jika router tidak melakukan komputasi ulang, dan berstatus active jika router masih melakukan komputasi ulang. Jika selalu tersedia feasible successor maka destination tidak akan pernah berada pada status active dan terhindar dari komputasi ulang. Status yang diharapkan untuk setiap network destination adalah status passive.

Routing table

3-routing-table

Router akan membandingkan semua FD untuk mencapai network tertentu dan memilih jalur/route dengan FD paling rendah dan meletakkannya pada tabel routing; jalur/route inilah yang disebut successor route. FD untuk jalur/route yang terpilih akan menjadi metric EIGRP untuk mencapai network tersebut dan disertakan dalam tabel routing.

Paket-Paket EIGRP

EIGRP saling berkomunikasi dengan tetangga (neighbor) nya secara multicast (224.0.0.10) dan menggunakan 5 jenis pesan (message) dalam berhubungan dengan neighbornya:

  • Hello: Router-Router menggunakan paket Hello untuk menjalin hubungan neighbor. Paket-paket dikirimkan secara multicast dan tidak membutuhkan.
  • Update: Untuk mengirimkan update informasi routing. Tidak seperti RIP yang selalu mengirimkan keseluruhan tabel routing dalam pesan Update, EIGRP menggunakan triggered update yang berarti hanya mengirimkan update jika terjadi perubahan pada network (mis: ada network yang down). Paket update berisi informasi perubahan jalur/route. Update-update ini dapat berupa unicast untuk router tertentu atau multicast untuk beberapa router yang terhubung.
  • Query: Untuk menanyakan suatu route kepada tetangga. Biasanya digunakan saat setelah terjadi kegagalan/down pada salah satu route network, dan tidak terdapat feasible successor untuk route/jalur tersebut. router akan mengirimkan pesan Query untuk memperoleh informasi route alternatif untuk mencapai network tersebut, biasanya dalam bentuk multicast tapi bisa juga dalam bentuk unicast untuk beberapa kasus tertentu.
  • Reply: Respon dari pesan Query.
  • ACK: Untuk memberikan acknowledgement (pengakuan/konfirmasi) atas pesan Update, Query, dan Reply.

Metric EIGRP

Protokol routing digolong-golongkan berdasarkan cara mereka memilih jalur terbaik dan cara mereka menghitung metric suatu jalur (route).  Metric adalah  suatu ukuran yang digunakan untuk menentukan nilai cost dari suatu route menuju network tertentu. Semakin kecil metric suatu route network semakin bagus dan akan menjadi pilihan utama dalam pemilihan route terbaik.

EIGRP menggunakan komponen-komponen metric yang sama seperti pada IGRP:  delay, bandwidth, reliability, load, dan maximum transmission unit (MTU).

EIGRP menggukaan gabungan metric yang sama seperti pada IGRP untuk menentukan jalur terbaik, hanya saja metric EIGRP dikalikan 256. EIGRP secara default hanya menggunakan 2 kriteria metric berikut:

  • Bandwidth.
  • Delay: total lama delay interface sepanjang jalur.

Kriteria berikut bisa dipakai, tetapi tidak direkomendasikan karena dapat menimbulkan kalkulasi ulang yang terlalu sering pada tabel topologi:

  •  Reliability.
  • Loading.
  • MTU.

Sumber Copas Dari Web sebelah jika ingin lebih detail tentang pembahasan ini maka silahkan kunjungi LINK DISINI

Cara Konfigurasi Cisco RIP Versi 1 dengan 3 Router

Salam Semangat bagi temen2 semua ,, 🙂

sudah sangat lama saya tidak pernah Posting Artikel ,sehingga saya binggung sendiri apa yang harus penulis tulis di dalam jendala wordpress ini ,akhir nya untuk mengisi kekosongan pada hari ini.penulis ingin memberikan 1 tutorial tentang jaringan yang berkaitan dengan cisco yaitu konfigurasi 3 router dengan menggunakan Rip versi 1 . sebenarnya sih ini adalah tugas yang di berikan oleh Pak Dosen dan saya rasa ini sudah sangat sederhana sih bagi  kaum yang terbiasa dengan jaringan komputer mohon di bantu ya ,,, hehe dan disini saya disuruh presentasi Kedepan kelas , karena saya mendapat nilai jelek di Ujian Tengah Semester ini tentang CCNA 2 sehingga saya disuruh buat presentasi untuk bisa di jelasin ke temen di depan kelas emangsih kalau udah nasip ,, mau gimana lagi .?? tapi tetap semangat .

Lebih detail  nya  silahkan simak tutorial berikut ini :

hasil

1. Gambarkan Desain Seperti terlihat diatas

2.Tentukan Router A , B , C untuk mempermudah kita pada saat konfigurasi

3.Insert Module Serial dalam setiap router Terlebih dahulu agar bisa Lebih Efektif dan Tentukan Alamat IP setiap Router

4. Router A Netword ID : 11.0.0.0 , Router B Network ID : 13.0.0.0 , Router C Netword ID : 13.0.0.0

5. Konfigurasi Router A dengan Menggunakan serial 0/0/0 dan serial 0/0/1  dan Fast Ethernet 0/0

Router#configure terminal
Router(config)#interface serial 0/0/0
Router(config-if)#ip address 11.0.0.1  255.0.0.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/0, changed state to down
Router(config)#interface serial 0/0/1
Router(config-if)#ip address 13.0.0.1 255.0.0.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 10.0.0.1  255.0.0.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

 

 

6.Konfigurasi Router B dengan Menggunakan serial 0/0/0 dan serial 0/0/1  dan Fast Ethernet 0/0

Router#configure terminal
Router(config)#interface serial 0/0/0
Router(config-if)#ip address 11.0.0.2 255.0.0.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up

Router(config)#interface serial 0/0/1
Router(config-if)#ip address 12.0.0.1 255.0.0.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to down

Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 172.16.0.1 255.255.0.0
Router(config-if)#no shutdown

Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

 

7. Konfigurasi Router B dengan Menggunakan serial 0/0/0 dan serial 0/0/1  dan Fast Ethernet 0/0

Router#configure terminal
Router(config)#interface serial 0/0/0
Router(config-if)#ip address 13.0.0.1 255.0.0.0
Router(config-if)#ip address 13.0.0.2 255.0.0.0
Router(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
Router(config-if)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up
Router(config)# interface serial 0/0/1
Router(config-if)#ip address 12.0.0.2 255.0.0.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface Serial0/0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/1, changed state to up

Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.0.1 255.255.255.0
Router(config-if)#no shutdown

%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
Router(config-if)#

Setelah Semua Router Telah Di konfigurasi Maka Saat Nya pemberian IP kepada Setiap Komputer yang ada

Komputer A

IP Address : 10.0.0.2

Mask         : 255.0.0.0

GateWay : 10.0.0.1

DNS          : Kosong

Komputer B

IP Address : 172.16.0.2

Mask         : 255.255.0.0

GateWay : 172.16.0.1

DNS          : Kosong

Komputer C

IP Address : 192.168.0.2

Mask         : 255.255.255.0

GateWay : 192.168.0.1

DNS          : Kosong

 

Setalah Semua komputer Sudah di berikan alamat IP maka tahap terakhir adalah Routing Setiap Router Dari A , B , C  dengan Cara :

Dalam Rip Versi 1 maka yang terhubung langsung ( direct ) dengan router tersebut harus di routingkan dan Rip versi 1 tidak mendukung VLSM mengenai materi kita bahas Kedepan ok ,, 🙂

Cara Routing Nya :

Router A

Router#configure terminal
Router(config-router)#network 11.0.0.0
Router(config-router)#network 13.0.0.0
Router(config-router)#network 10.0.0.0

Router B

Router#configure terminal
Router(config-router)#network 11.0.0.0
Router(config-router)#network 12.0.0.0
Router(config-router)#network 172.16.0.0

Router C

Router#configure terminal
Router(config)#router rip
Router(config-router)#network 13.0.0.0
Router(config-router)#network 12.0.0.0
Router(config-router)#network 192.168.0.0

alhamdulillah AKhir nya Tutorial Konfigurasi 3 router cisco dengan menggunakan Rip Versi 1 selesai juga Saya tulis ,, semoga Dapat Bermamfaat dan selalu sukses Bagi yang membaca Termasuk Penulis yang akan Presentasi Pada Hari Rabu jam 7:30 amin Ya rabbal Alamin .

Sampai Jumpa Pada Tutorial berikut : 🙂 🙂 🙂

(Java) Membuat aplikasi Absen

Tag

, , , , , , , , , ,

Salam Super buat para pecinta blog dan media sosial yang lain nya . Selama ini banyak yang kejadian yang  terlewati dan tanpa ada jejak . ini disebabkan oleh kesibukan saya yang tidak menentu sehingga penulispun merasaka kaku ketika menulis di jedala maya ini . baiklah pada kali penulis membahas bagaimana membuat aplikasi absen yang memamfaatkan kamera pada laptop kita sendiri .awal nya ide ini timbul karena salah satu dari temen kami mengadakan sebuah pertemuan di suatu tempat dan ia membutuhkan data yang cepat dan akurat ini di hadiri oleh setiap mahasiswa yang aktif di organisasi dari sinilah timbul ide bagi penulis untuk menciptakan sebuah aplikasi yang berjudu Absensi menggunakan Camera.

Pertama ini merupakan hal yang tidak biasa di kalangan kami , mungkin di kalangan temen – temen yang sudah sering bergelut di dunia IT ,mungkin ini hanya sederhana dan sudah banyak yang buat . untuk membuat aplikasi ini ada beberap Library yang harus di download terlebih dahulu sebelum mebuat projet ini.Yaitu :

1.Lib Jmf pada Java dan Jaspereport

2.Ini Donwload Project Nya

Untuk Library nya saya rasa cukup 2 saja selanjut nya mari kita lihat jendela hasil Aplikasi pada NetBeans 7.1

Camera

Report

oh ya ,,, jangan lupa jika ingin mencoba database nya juga dimasukin ke Xampp terserah sama pengguna .

sekian dulu ya dari saya semoga bermamfaat.:) salam Develper

 

Inheritent

Semua attribute dan method dari suatu kelas super dapat diwariskan ke subkelas.
Dalam hirarki kelas, jika kelas C merupakan turunan kelas B, dan kelas B merupakan turunan kelas A, maka otomatis attribute dan method kelas A juga diwariskan kelas C.

Manfaat Pewarisan

Tanpa inheritance, maka semua attribute dan method yang pernah dibuat dan butuhkan kelas lain, harus ditulis ulang seluruhnya.Dengan inheritance, seorang programmer ingin
memodifikasi suatu attribute ataumethod yang dimanfaatkan subkelas, maka dilakukan modifikasi attribute dan method tersebut pada kelas supernya.5.5. Overrriding Attribute dan Method Overriding adalah emampuan suatu subkelas untuk memodifikasi attribute dan method milik kelas supernya (tentu yang memiliki sifat private atau final tidak biasa dilakukan overriding). Modifikasiyang dilakukan, misalnya jumlah parameter, tipe arameter, tipe return value, ataupun lingkungan pemrosesan datanya.

// Contoh program overriding
class KelasSuper {
public void methodAsli() {
System.out.println( Method milik KelasSuper jalan );
}
public static void main(String[] args) {
KelasSuper oks = new KelasSuper();
oks.methodAsli();
}
}
class SubKelas extends KelasSuper {
public void methodAsli() {
System.out.println( Method yg overrided jalan );
}
public void methodPemanggil() {
System.out.println( Method pemanggil methodAsli jln );
super.methodAsli(); // yg dipanggil milik kelas super
}
public static void main(String[] args) {
SubKelas osk = new SubKelas();
osk.methodAsli();
osk.methodPemanggil();
}
}

Contoh sederhana agar dapat di pahami bagi pemula belajar java…

Php FundaMental

Cuman Iseng iseng nulis .. untuk apa yang sudah di pelajari di kampus .. tentang matakuliah pemograman web

Semicolon (;)

Apabila Anda perhatikan contoh sebelumnya, maka terdapat tanda titik koma (semicolon) pada akhir perintah echo. Tanda semicolon merupakan penanda akhir dari statement PHP dan harus ada.

Contoh

Halaman PHP

Variabel

Misalkan dalam PHP kita akan menyimpan suatu nilai berupa angka atau string dalam suatu variabel, caranya adalah membuat nama variabel terlebih dahulu kemudian diberikan suatu assignment pada nilai yang diinginkan. Perhatikan sintaks berikut ini: Baca lebih lanjut